Agent Deployment fails to upgrade all files.

VERSION 1 Published

Created on: Nov 15, 2007 11:55 AM by LANDesk Support - Last Modified:  Nov 15, 2007 12:07 PM by LANDesk Support

 

Description

 

 

After upgrading to the latest service pack and then deploying new agents, remote control fails or the icon is not appearing.

 

 

Some machines are not showing a new cba8 version in their inventory.

 

 

Cause

 

 

All of the new client files were not installed or copied.

In some cases problems after upgrade are caused by streams being present either with the new service pack or on LANDesk files prior to the upgrade. Streams is a security feature recently released by Microsoft. If files have been downloaded and installed from a non-trusted source, then it is necessary to remove the data stream from the file that is flagged as a non-trusted file.

 

 

Resolution

 

 

1) Ensure the latest cba8inst.msi files are present on the core and agents.

 

If the CBA8 version is not updated with the agent install to the correct version, manually replace the following files using files from a working core at the correct service pack level:

 

 

CBAinst.msi & httprequest.dll

 

 

These files belong in the ldlogon share on the core server. After replacing the files rebuild all in the agent configuration menu of LDMS and redeploy the agent.

 

2) If present, remove the datastreams from the LDMS files.

 

To remove the data stream from a directory structure, download streams.exe from Microsoft Inc at the following location.

 

http://www.microsoft.com/technet/sysinternals/utilities/Streams.mspx

 

Open a command prompt window and execute streams with the following syntax:

streams.exe -d -s C:\Progra~1\LANDesk\

streams.exe -d -s C:\inetpub\

 

 

Also run the above command against any location containing landesk patches, service packs, or other files.

This deletes the datastream and runs recursively through subdirectories.

 

For more information refer to Microsoft article 889815.

 

In some cases other files may not have been updated or copied, these files can be copied from a working core to the affected core. However it is possible there may be too many missing or corrupted files in which a repair is nessasary, followed by re-applying the service pack. In these instances ensure the landesksoftware.exe and the servicepack zip are not blocked. Apply locally at the core.

 

3) The client machine is missing the .0 certificate files.

 

To resolve this issue, manually copy the .0 file from the LDLOGON directory on the core to the following directory on the client:

 

C:\Program Files\LANDesk\Shared Files\cbaroot\certs

 

 

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