|
||||
Problem
Pushing the LANDesk Agent via a scheduled task fails and returns the following error:
"Failed to build the agent installation package”
Cause
A file required to build the agent package is missing. The most recent ManagementSuite\log\cab_xxx.log will likely refer to a missing file. The first step in resolving this issue is to determine which file is missing, so start by looking in that file for a line that looks like this:
Add file [http://filename.ext|http://filename.ext] failed!
Resolution
1. If the missing filename is LDAPPL3.ini
The ldappl3.ini file is either missing from the ldlogon folder or is corrupt. This is currently the most common cause. If this is the case-
Delete any ldappl3.xxx files from the ManagementSuite\LDLOGON folder EXCEPT for the ldappl3.template. (Make sure the .template file does not have a .bak extension and that the ldappl3.template file exists. Without the .template file the ldappl3.ini file will not get created.)
Open the Console and go to Tools | Reporting / Monitoring | Software License Monitoring.
Click on the ‘Make Available to Clients’ button (this recreates the ldappl3.ini and corresponding ldappl3.xxx files).
Rerun the agent install task.
2. If the missing filename is ldapwhoami, processrunner.dll, rchelper.dll, or sdistmsi.exe and the core is LANDesk 8.7 with SP3:
a.Download and apply hotfix CLN-11569687.3:
http://community.landesk.com/downloads/patch/CLN-11569687.3-2.zip
or
b. Download and apply the latest service pack:
Download the latest Service Pack for LANDesk Software products
3. If some other file is missing-
Determine which file is missing and try to locate and replace it. The file may have been inadvertently moved or deleted.
Another possible cause of this issue is the streams issue. More information about this issue and how to solve it can be found here: Error: "Unknown publisher. Do you want to continue?"
There are no comments on this document
|
|||||