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How to troubleshoot missing or empty alert rules or rulesets after an 8.8 Server Manager install or upgrade

VERSION 1

Created on: May 2, 2008 2:41 PM by Brandon Hill - Last Modified:  May 2, 2008 3:38 PM by Brandon Hill

Description

 

Alert rules or rulesets may be missing after installing or upgrading Server Manager to 8.8 from an older version.

For instance when editing an alert, left clicking on Disk Space in the Monitoring section may not have alert information or default built-in alerts. In other instances the default alert rulesets such as Core Alert Ruleset etc. may not exist in the console.

 

This issue applies to LDMS 8.8 with Server or System Manager.  It does not apply to users who are not licensed for System or Server Manager or users who have not installed these components.

 

This document assumes the user is experienced in both Management Suite and System/Server Manager.

 

Cause

 

This can be caused by the circumstances described in defect 9497. If you installed LDMS 8.8 from the release build and then later did a Modify install to add LDSM 8.8, not all rulesets or rules were populated in the database.

This may have other causes related to missing or corrupt files or missing entries in the database.

 

Resolution

 

Caution: As this modifies the database it should not be used on critical production cores or databases that are not backed up. NOTE: The steps in the Resolution must be run on the core server in the order shown below, each command must run successfully without errors. 1) From a Command Prompt browse to the following folder: "c:\Program Files\Landesk\ManagementSuite\" (drive letter may vary by installation) 2) Run the command: alertname2table.exe -c

You will see feedback in the command window and it will say done if it completes running.

3) Run the command: alertruleset2table.exe -v -c "c:\Program Files\Landesk\ManagementSuite\alertrulesets"

This will open a dialog box which will display its process, it will say 8 or 9 processed at the end if successful. The number of files processed depends if System Manager is installed or not.

4) Re-open the console.

 

Additional Notes:

 

When running alertruleset2table.exe -v -c there will be a lot of information displayed in the dialog box. It displays which xml file it is processing and the rules it contains. The alert rules will have names based on their alert, so do not be concerned by alert names that contain errors like ldappl corrupt etc.

 

Here is a sample of the xml files that are processed. The lsm.default.ruleset.xml will not be processed if System manager is not installed.

 

Processing ruleset information in C:\Program Files\LANDesk\ManagementSuite\alertrulesets\core.ruleset.xml

Processing ruleset information in C:\Program Files\LANDesk\ManagementSuite\alertrulesets\corerc.ruleset.xml

Processing ruleset information in C:\Program Files\LANDesk\ManagementSuite\alertrulesets\default.ruleset.xml

Processing ruleset information in C:\Program Files\LANDesk\ManagementSuite\alertrulesets\defaultipmi.ruleset.xml

Processing ruleset information in C:\Program Files\LANDesk\ManagementSuite\alertrulesets\defaultrc.ruleset.xml

Processing ruleset information in C:\Program Files\LANDesk\ManagementSuite\alertrulesets\ldms.core.ruleset.xml

Processing ruleset information in C:\Program Files\LANDesk\ManagementSuite\alertrulesets\ldms.default.ruleset.xml

Processing ruleset information in C:\Program Files\LANDesk\ManagementSuite\alertrulesets\lsm.default.ruleset.xml

Processing ruleset information in C:\Program Files\LANDesk\ManagementSuite\alertrulesets\provisioning.ruleset.xml

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