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Unable to delete nodes from the LDMS Console.

VERSION 3

Created on: Jul 2, 2008 10:48 AM by ponderosa - Last Modified:  May 18, 2009 8:27 AM by LANDarin

Description

After deleting a node from the LDMS Console and refreshing the node pops back up into the list.

 

Console.exe.log:

3/7/2008 10:03:56 AM : Critical Exception: System.Runtime.InteropServices.SEHException: External component has thrown an exception.

at IDALLib.IDALRecordsetClass.DeleteDevices(String conStr, Object& pvtDevices)

 

Or:

 

Database.ExecuteDataTable: System.Data.OleDb.OleDbException: Invalid object name 'AlertRulesetDeployment'.

 

Key Words: Unable to Delete Nodes, Can not Delete Nodes, Cannot Delete Nodes, Unable to Delete Devices, Can not Delete Devices, Cannot Delete Devices.

 

Cause

A database table is being referenced in the delete query that no longer exists. The list of tables is created from the METAOBJATTRRELATIONS table.

 

Resolution

1. Stop LANDesk services

2. Backup DB

3. Run the following SQL Query:

delete from METAOBJATTRRELATIONS where tablename in (select distinct tablename from METAOBJATTRRELATIONS where tablename not in(select table_name from information_schema.tables))

 

Run DBRepair.exe Then CoreDBUtil.exe

 

-DBRepair

1) Download the Correct version of DB Repair from: Community Doc DOC-2297

http://community.landesk.com/support/docs/DOC-2297

2) Copy the file to ...\LANDesk\ManagementSuite

3) Stop the LANDesk Inventory Server Service

4) Run DBRepair (DO NOT Run from a share (ldmain))

5) Click on each item except for anything under "Custom Data" and click the clean button

6) Close DBRepair

 

-CoreDBUtil

1) Run CoreDBUtil.exe from ...\LANDesk\ManagementSuite\

2) Click the Build Components button (This compares the database to the file Datamart.xml and makes repairs. It usually takes 5-15 minutes. DO NOT Stop the process!!!)

3) When the Build Components process finishes A Message will appear that says

4) Close CoreDBUtil

5) Start the LANDesk Inventory Server Service

 

DBRepair can be found here:

http://community.landesk.com/support/docs/DOC-2297

 

Start the LANDesk Services that had been stopped in step 1.

 

 

NOTE: An issue has been resolved with the upgrade from 8.7 SP5 to 8.8 with the following SQL Query:

 

Update metaobjattrrelations set tablename = 'UNMODELEDDATA' WHERE TABLENAME = 'ALERTRULESETDEPLOYMENT'

 

Article on how to install Microsoft SQL Management Studio Express and Run a query:

http://community.landesk.com/support/docs/DOC-5764

Paul Hoffmann Paul Hoffmann  says:

Good article - thanks!

 

While this is usually correct (by which I mean, I've seen at least 3 instances where it was this table that causes the problem), this isn't necessarily ALWAYS the case.

 

Other problems or corruption of the metadata can cause this issue to come up - if this article does not resolve your issue, contact LANDesk support and provide them with a backup of your database. We'll see what's causing the problem then.

 

If you're not afraid of SQL traces, you can figure our what table you're failing on yourself, and fix the problem that way yourself, if you want (always safer to double check with us though)

 

Paul Hoffmann

LANDesk EMEA Technical Lead.

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