Skip navigation
12350 Views 6 Replies Latest reply: Aug 26, 2009 11:51 AM by Froggmann RSS
Rookie 10 posts since
May 2, 2008

Has received 1 of 9 achievements.
Currently Being Moderated

May 2, 2008 6:34 AM

8.8 Console and Vista - Requested registry access is not allowed.

 

Hey Guys, just new to LANDesk here.  Trying to login to the 8.8 console on vista.  I get the following error "Requested registry access is not allowed."  What security settings do I need to change to grant access?

 

 

 

 

 

Thanks

 

 

  • Employee 620 posts since
    Dec 12, 2007

    Has received 6 of 9 achievements.

    Add the group LANDesk Management Suite, with full access permission to the key :

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\winreg on the core

  • Rookie 6 posts since
    May 27, 2008

    Has received 1 of 9 achievements.

    Hello Ty,

     

    I have the same issue, so I take the chance to reply. the group LANDesk Management Suite is already in the permisson of the folder " winreg " with full acces but

     

     

    it wont open it, same error message " Console Initialization error - Requested regitry access is not allowed ". I'm running a vista business 32 bits without sp1.

     

     

    Work fine with an xpsp2

     

     

    Thanks.

  • Expert 17 posts since
    Mar 26, 2008

    Has received 2 of 9 achievements.

     

    The permission added to the winreg key depends on your right to authenticate to the core server over the LAN.  The username and password you use to log into Windows will be passed when attempting to access the remote registry.  You can check if you have rights to the remote registry by doing the following:

     

     

    1)  On the computer you are trying to use the remote console go to Start | Run: Regedit  2) Go to File | Connect Network Registry...   3)  Enter the host name of the core servr and click OK   4) Try to Open HKEY_LOCAL_MACHINE on the remote registry.

     

     

    If you receive an error then the user that you are logged into Microsoft Windows as does not have permission on the core server.

     

     

  • Froggmann Apprentice 55 posts since
    May 20, 2009

    Has received 1 of 9 achievements.

    BTW this solution works even when your "civilian" account is just given read access to the key Ty mentioned. I have the console loaded up and running on my Windows 7 box at the moment.

  • mcmullina Rookie 30 posts since
    Apr 24, 2008

    Has received 1 of 9 achievements.

    How did you get the console to install on Windows 7.  I have the 64 bit version.  When I try to run it I get the compatibility error.

    Thanks

  • Froggmann Apprentice 55 posts since
    May 20, 2009

    Has received 1 of 9 achievements.

    I should have specified, It works on 32 bit but it freaks out on 64 bit. Until a 64 bit client is built you will be stuck running it on a 32 bit box or run it from Virtual XP.

     

    Before I got it to work, I had it running on a virtual XP installation and it ran OK. Just after a month and a half or even two months can't remember which the virtual machine started to get a little wiggy. In the end I would have to open up the image, start it, login, close it then start the virtual application. But then again the box I ran it off of was a laptop and it was being shutdown and restarted daily.

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 20 points
  • Helpful Answers - 10 points
LANDESK Community powered by Jive SBS® 4.5.7.1  |  Legal Notices  |  Privacy Policy  |  Icon 

TweeterOn Twitter  |  Icon FacebookOn Facebook © 2007 LANDESK Software