Skip navigation
10353 Views 6 Replies Latest reply: Feb 2, 2010 7:38 AM by EMiranda RSS
jmichno Apprentice 204 posts since
Jan 11, 2008

Has received 1 of 9 achievements.
Currently Being Moderated

Sep 13, 2009 1:43 PM

Prompting for drivers instead of using windows\inf

Has anyone else had this issue or know how to fix it?

 

When I perform an OSD, everything applies correctly, my drivers copy down fine, and I think te ldprep is working as expected.

But, for some reason, when I boot into windows, I receive messages asking to install drivers.

I simply point to c:\windows\inf, and the drivers are found and installed, but why does windows not know to check there instead of ask me?

Is there something I am missing in the registry? or in LDprep?

 

So far the only way around this has been to limit my images to the exact model of machine, thus no HII.

 

Info:

LANDesk 8.8sp2a

Windows SP2 - slipped streamed XP with SP2 cd.

Lenovo desktops and laptops (SATA & IDE)

 

Any help would be appreciated.

  • phoffmann SupportEmployee 2,643 posts since
    Dec 11, 2007

    Has received 7 of 9 achievements.
    Currently Being Moderated
    2. Sep 15, 2009 1:32 AM (in response to jmichno)
    Re: Prompting for drivers instead of using windows\inf

    There "shouldn't" be anything missing - it's fairly straight forward stuff.

     

    The best approach here would be to try and see with Microsoft what can be done to troubleshoot / debug-log what Sysprep is up to. My sneaking suspicion though is that the answer to this one is "very little" - and the crux here is that one would need to find out what Windows EXPECTS versus what it FINDS (hence the debug logging).

     

    Could be as simple as a typo in the paths or whatnot, but it's really sysprep that you need to trace here, more than anything. Since our stuff works (and we don't double check the content), it'd help to know what sysprep is having reason to be complaining about - i.e. why it's going wrong.

     

    Not one of the easiest / most straight forward places to be troubleshooting, I'm afraid .

     

    - Paul Hoffmann

    LANDesk EMEA Technical Lead.

  • Employee 176 posts since
    May 8, 2008

    Has received 4 of 9 achievements.
    Currently Being Moderated
    3. Sep 18, 2009 5:27 PM (in response to jmichno)
    Re: Prompting for drivers instead of using windows\inf

    Sounds a lot like this article: http://community.landesk.com/support/people/jan.buelens/blog/2009/05/06/osd-provisioning-is-mini-setup-prompting-your-for-the-installation-media. Or, if the driver you're being prompted for is not a microsoft supplied one, try this article

  • dynamozappa Apprentice 107 posts since
    Dec 17, 2007

    Has received 1 of 9 achievements.

    Hi Jan....i tried injecting the SP3.cab file into my provisioning template and I am still getting prompted to install drivers for the keyboard and mouse after the machine is imaged.

     

    I was wondering if you had any insight as to why this is happening. Does the SP3.cab file need to be unzipped or something?

     

    thanks.

     

    jeff

  • Employee 176 posts since
    May 8, 2008

    Has received 4 of 9 achievements.

    When I wrote this article, I had been tearing my hair out for days and I couldn't understand why I was being prompted for files that were already on board. I forget all the things I tried or how eventually I found the solution, but I know for definite that all it took to get rid of the problem was to have sp3.cab sitting there in the right place. I didn't unpack it. This only works for out-of-the-box WinXP drivers, not for OEM drivers.

     

    If you're really, really sure that you copied the right file to the right place, then I'm afraid I don't know what to suggest. I can only say what's worked for me and a bunch of other people, but it may not be the full story.

  • EMiranda Expert 681 posts since
    Aug 26, 2009

    Has received 7 of 9 achievements.

    I've had some models with HII that would prompt for drivers in sysprep even though i had all my drivers in the right space.  For some odd reason on these particular models, they were looking for drivers in the sysprep\$oem$\  folder.  When the message prompts for the driver, it will show you the driver path that windows thinks the driver is supposed to be.

     

    I couldn't figure it out, but as a workaround, i just injected the file it wanted in that folder on the image and all was good.  This may not be related to your situation, but thought at least I share incase it can lead you in the right direction.

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 20 points
  • Helpful Answers - 10 points
LANDESK Community powered by Jive SBS® 4.5.7.1  |  Legal Notices  |  Privacy Policy  |  Icon 

TweeterOn Twitter  |  Icon FacebookOn Facebook © 2007 LANDESK Software