Skip navigation
10962 Views 14 Replies Latest reply: Jun 3, 2011 11:16 AM by fdarst RSS
tfitzpatrick Rookie 45 posts since
May 20, 2008

Has received 1 of 9 achievements.
Currently Being Moderated

Mar 19, 2010 12:19 PM

HII Error Downloading drivers

This is the first time we're trying to use HII with LD9.  The issue we are having is that some of the driver files get downloaded from the core to windows\lddriverstore but others do not.  Is there a log that would show why the download of the drivers are failing?  Or does anyone know of any troubleshooting tips?

  • Mach6 Employee 637 posts since
    May 23, 2008

    Has received 6 of 9 achievements.
    Currently Being Moderated
    1. Mar 19, 2010 12:36 PM (in response to tfitzpatrick)
    Re: HII Error Downloading drivers

    What are the filenames of a few of the files that aren't downloading?

     

    Also, there is a log called hiiclient.log located either in the X:\LDClient folder in WinPE or the X:\Windows\System32 folder in WinPE.  You can run a task with HII, but edit the script to not reboot when it's completed so you can view the log file.

  • Mach6 Employee 637 posts since
    May 23, 2008

    Has received 6 of 9 achievements.
    Currently Being Moderated
    3. Mar 19, 2010 2:15 PM (in response to tfitzpatrick)
    Re: HII Error Downloading drivers

    Couple questions:

    1 - How big is your image?

     

    2 - What is the total size of the drivers you are bringing down?

     

    3 - How many drivers are you bringing down?

  • EMiranda Expert 681 posts since
    Aug 26, 2009

    Has received 7 of 9 achievements.
    Currently Being Moderated
    5. Mar 19, 2010 5:00 PM (in response to tfitzpatrick)
    Re: HII Error Downloading drivers

    LANDesk HII will not download any .exe files.  Im pretty sure its mostly .inf files.  There are only a few driver files it does support, I can't remember which ones, .inf, .cat, etc.

     

    Normally if you have a file that is not supported in HII the gui produces a red exclamation circle and will not allow you to save.

  • johnk Apprentice 43 posts since
    Dec 14, 2008

    Has received 1 of 9 achievements.
    Currently Being Moderated
    6. Jan 13, 2011 10:13 PM (in response to tfitzpatrick)
    Re: HII Error Downloading drivers

    Hi,

     

    I am too getting the same issue. using HII some files do not copy, so the drivers to not install i.e. If I compare the Graphics Driver directory in HII there are 100 files but only 72 files were copied. very strange..

    Let me know if you found a solution

     

    Thanks

  • johnk Apprentice 43 posts since
    Dec 14, 2008

    Has received 1 of 9 achievements.
    Currently Being Moderated
    7. Jan 16, 2011 3:56 PM (in response to tfitzpatrick)
    Re: HII Error Downloading drivers

    For anyone who comes across this issue give this a shot. Some driver files had the .resource extension and IIS was denying downloading these files via http

     

    http://community.landesk.com/support/docs/DOC-9230

    http://support.microsoft.com/kb/942045/

  • spriefer@chausa.org Rookie 27 posts since
    Sep 15, 2010

    Has received 1 of 9 achievements.
    Currently Being Moderated
    8. Jan 28, 2011 4:25 PM (in response to tfitzpatrick)
    Re: HII Error Downloading drivers

    Non of my drivers downloaded.  I confirmed by manually loading the drivers that they were correct.  My log just shows msd injection fail as well as shows the entire database structure.  I just have the folder structure but no files when i get to the end.

  • AspenSkier Specialist 479 posts since
    Apr 29, 2010

    Has received 3 of 9 achievements.
    Currently Being Moderated
    9. Feb 3, 2011 11:36 AM (in response to EMiranda)
    Re: HII Error Downloading drivers

    RE: the RED CIRCLE w/exclaimation mark when attempting to add drivers to the HII database in LDMS 9.0

     

     

    When I went to Landesk training in Salt Lake last year I asked about this; I was told that the HII tool in the console is specifically looking for an .INF before it will allow you to add the drivers to the database.  I believe I was looking in the ROOT folder of a given driver download and there was no .INF there, however there were INFs burried in subfoldes.  My Landesk trainer told me to simple create an empty .INF file, called oemsetup.inf in the root and then the console would permit the drivers to be installed.

     

    So I've been doing this since then but recently I started to take another look at it.

     

    I've decided that my trainer either didn't know what he was talking about or he just wanted to shut me up so that he could carry on with his class.

     

    Whatever the case may be I have decided that HII with LDMS 9.0 is not the end of the road when it comes to driver installs.  I've observed that most of the drivers that were installed on my Windows 7 machines were microsoft copies rather than the ones that I meticulously added to LDMS, many of which initially reported the RED CIRCLE but were added anyway courtesy of the empty OEMSETUP.INF files I created.

     

    I have since found this thread which sheds light on a way to install drivers which come with .EXE installers.

     

    http://community.landesk.com/support/docs/DOC-8674

     

    Here is an abstract from the document:

     

    "

    One of the problems that I have seen with LANDesk 9 HII is the inability to load Setup.exe drivers during the HII process.  To many, this is a big deal because a lot of drivers these days require applications to run them, One example is the HP Quicklaunch buttons for laptops. Which have drivers embedded in the executable and the application is required to use the driver like On Screen Display messages.  I personally like to have those installed on my models.

     

    Here is a workaround that I have found that is quite successful in getting this job done with a little AutoIT scripting.  Wmi_model.exe will detect your System Model and deploy another script based off of that system."

     

     

    With all of the work I'm putting into testing the solution provided there I am essentially doubling my work and then some and I am starting to see HII as falling WAY SHORT of the billing it received when I was sold this product.

     

    I can't wait for an actual Landesk employee to join in on this discussion and tell us all how LDMS 9.0 is supposed to handle this...or at least tell us that Landesk is working on a way to include .exe files in HII.

  • EMiranda Expert 681 posts since
    Aug 26, 2009

    Has received 7 of 9 achievements.
    Currently Being Moderated
    10. Feb 3, 2011 11:43 AM (in response to AspenSkier)
    Re: HII Error Downloading drivers

    I agree that right now HII falls way short right now when only using what LANDesk provides out of the box.  I think its crazy that one of their own employees Jan Beulens helped develop an HII process that is nearly flawless that has been around for quite some time (which I still use to this day).  I hope that the future of HII gains more focus and not be so dependent on "workarounds"

  • AspenSkier Specialist 479 posts since
    Apr 29, 2010

    Has received 3 of 9 achievements.
    Currently Being Moderated
    11. Feb 3, 2011 11:45 AM (in response to EMiranda)
    Re: HII Error Downloading drivers

    thanks

     

    would you care to elaborate on this 'other' HII process...?

  • johnk Apprentice 43 posts since
    Dec 14, 2008

    Has received 1 of 9 achievements.
    Currently Being Moderated
    13. Feb 3, 2011 2:58 PM (in response to EMiranda)
    Re: HII Error Downloading drivers

    HII was working for me but it just took too long over http to copy the drivers across and my imaging would take more than 1 hour. All I did was make a new dierctoy under %servername%\ldmain\landesk\files called "driverManualCopy" then made a directory for each model Laptop/desktop i.e.

     

    ..\ldmain\landesk\files\mydrivers\m58p

    ..ldmain\landesk\files\mydrivers\T4510... etc..

     

    FolderStructure.gif

     

    Put all the correct drivers in the required folder.

    Then under provisioning Post-OS Installation create a new copy file action and copy the drivers to the D:\Windows\LDDriverStore

    CopyDrivers.png

    Now make sure you have the following in your unattend.xml script

     

    <component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
          <DriverPaths>
            <PathAndCredentials wcm:keyValue="1" wcm:action="add">
              <Path>c:\windows\LDDriverStore</Path>
            </PathAndCredentials>
          </DriverPaths>
        </component>

     

    and this

     

    <component name="Microsoft-Windows-PnpSysprep" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
          <PersistAllDeviceInstalls>true</PersistAllDeviceInstalls>

     

     

    This will force WIndows to install the drivers.

    This worked for me.

     

    With exe drivers I used a tool called "Driver Magician". This allowed me to install all drivers on a Laptop/Desktop then run Driver Magician and backup these drivers (Including inf files) to a directory.

    Alternatively you can make a distribution package for the exe and install silently once the operating system boots up.

  • Rookie 3 posts since
    Apr 14, 2010

    Has received 1 of 9 achievements.
    Currently Being Moderated
    14. Jun 3, 2011 11:16 AM (in response to tfitzpatrick)
    Re: HII Error Downloading drivers

    I am having the same problem. It seems that when I try to reimage more than two computers not all of the drivers will copy over during os deployment. I can boot back into WinPE and manually copy them. I haven't taken a look at the HII log file. I will definitely do that on the next failure.

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • Correct Answers - 20 points
  • Helpful Answers - 10 points
LANDESK Community powered by Jive SBS® 4.5.7.1  |  Legal Notices  |  Privacy Policy  |  Icon 

TweeterOn Twitter  |  Icon FacebookOn Facebook © 2007 LANDESK Software