Skip navigation
10503 Views 11 Replies Latest reply: Mar 28, 2012 12:53 PM by Andy Martinez RSS
michaelakorita Rookie 15 posts since
Jun 16, 2009

Has received 1 of 9 achievements.
Currently Being Moderated

Nov 10, 2010 9:05 AM

drvmap error during image deployment

Has any one come across this before?

 

the log file content is

 

"Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"
"6C626D600B72","OK",0,0:00:00,10/11/2010 16:03:22,10/11/2010 16:03:22,"WINPE, TIMEOUT=1800"
"6C626D600B72","ERR_Fail",-1917190229,0:02:01,10/11/2010 16:03:22,10/11/2010 16:05:23,"ldrun drvmap.exe domain\user 108963DCA25014948241461720C I: """\\landeskserver\OSImages""", STATUS FACILITY=3513"
; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"

 

red coloured text has been edited for security reason.

  • Employee 620 posts since
    Dec 12, 2007

    Has received 6 of 9 achievements.
    Currently Being Moderated
    2. Nov 10, 2010 9:12 AM (in response to michaelakorita)
    Re: drvmap error during image deployment

    Are you using HII.  If so see below.  There is a known issue with HII in sp2.

     

    Workarounds:

     

    OSD – Modify the OSD script on the line that calls HIIclient.exe.  Remove the “/UNCPath=\\<coreserver>\ldmain\landesk\files\drivers” from the REMEXEC line calling HIIclient.exe.  This will revert the process to go back to the http path.

     

    Provisioning – Add an execute file action after the HII action to run the following command:  x:\ldprovision\HIIClient.exe /autodetect /ostype=”Windows7” (or /ostype=”WinXP”).  This will re-run HIIclient.exe and revert back to the http path.

  • cplatero SupportEmployee 90 posts since
    Mar 7, 2008

    Has received 4 of 9 achievements.
    Currently Being Moderated
    4. Nov 15, 2010 4:13 PM (in response to michaelakorita)
    Re: drvmap error during image deployment

    That failure indicates that it couldn't copy the .xml file to the client.  Often that is caused by the Imaging not working.  If you paste the whole log I may be able to see why.

  • Rookie 8 posts since
    Sep 17, 2010

    Has received 1 of 9 achievements.
    Currently Being Moderated
    6. Jan 31, 2011 3:44 AM (in response to michaelakorita)
    Re: drvmap error during image deployment

    Hello,

     

    I had the same problem.

     

    I have Landesk Management Suit 9.0 SP2

    I made an OSD image of a windows 7 with sysprep

     

    And when i tried to Deploy the image i had the dos console with DRVMAP.EXE  then nothing.............. (i ever deployed many xp stations that worked well)

     

    I've tried many things :

    - find and inject the disk drivers

    - update the bios of the client

    - tried many other drivers

     

    but nothing worked

     

    those are the logs :

     

    "Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"
    "DIT-WKS-10","OK",0,0:00:00,31/01/2011 10:29:12,31/01/2011 10:29:12,"WINPE, TIMEOUT=1800"
    "DIT-WKS-10","ERR_Fail",-1917190229,0:02:00,31/01/2011 10:29:12,31/01/2011 10:31:12,"ldrun drvmap.exe CARPENTRAS\administrateur 20B7D05B366EF760544D902404356B727185F I: """\\Img-srv-01.CARPENTRAS.FR\IMAGES_LANDESK""", STATUS FACILITY=3513"
    ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"

     

     

    So i've edited the osd script and change the drive letter that DRVMAP was trying to map to from I: and H: to Z: and Y: and it's mapped the drives correctly.

     

    And the image worked !

     

    I just want to know why we had to make those modifications, cause i lost 3 days on this problem.

     

    Thx

  • Rookie 27 posts since
    Aug 13, 2010

    Has received 1 of 9 achievements.
    Currently Being Moderated
    7. Feb 3, 2011 6:47 AM (in response to xavier.usclat)
    Re: drvmap error during image deployment

    I am in the same boat here as well, but we are running OSD scripts for XP. To give more detail the key peice I have noticied is that it only fails on HII scripts. When I have compared HII and non-HII scripts the key difference is that it does not need to map drive i: and h:. This started happening back in December at the end of the month for us and we are using 9.0 SP2. We had been on SP2 for about a month and a half and we had not applied any patches around the time that this happened. After SP2 was applied we had no problems. No one was able to identify any changes that we made to the core around that time at all.  I have been creating scripts, but it is getting very annoying creating scripts and then after each time I need to edit them I need to edit i: to z: and h: to y:. It does solve the problem, but I see this as a temporary solution. Here is a dump of a script that works correctly with the drive letter modifications. I have modified key peices that I consider a security threats with (***DESCRIPTION***). I have also noted the locations of the drive letters that have been changed into red text.

     

    [VALUES]
    Task=8
    ScriptName=D-MAN-LT-XP(32)
    ScriptDescription=
    MCast=0
    FallBackNIC=
    UseFallBackNIC=FALSE
    ImageUserName=(*****USER******)
    ImageDomain=(***DOMAIN***)
    ImagePassword=(*******PASS HASH********)
    ImageToolType=11
    ImageUNC=\\blnfs01\landeskimages\LAB\XP(32)\Live\FTM-HII-012.TBI
    ToolUNC=\\wddlds01\ldmain\osd\imagew 2\imagew.exe
    Partition=1

    ImageToolCmd=Y:\osd\IMAGEW~1\imagew.exe /r /o /d:0 /f:"""Z:\LAB\XP(32)\Live\FTM-HII-012.TBI""" /rb:0

    ImageToolCmdsFile=\\WDDLDS01\LDMAIN\LANDESK\FILES\D-MAN-LT-XP(32).txt
    IsSysPrepImage=1
    IsVistaSysPrep=0
    UseExistingSysPrep=0
    ExistingSysPrepFile=
    SysPrepFile=\\WDDLDS01\LDMAIN\LANDESK\FILES\D-MAN-LT-XP(32).inf
    RemoteSysPrepCopyPath=c:\sysprep\sysprep.inf
    SysPrepTargetedType=0
    UseInventoryName=1
    ComputerNameTemplate=MAN-LT-nnn
    ComputerNameStartNumber=1
    ClientInstallDomain=(***DOMAIN***)
    ClientInstallUsername=(***USER***)
    ClientInstallPassword=(*****PASS HASH******)
    ClientInstallUNC=\\wddlds01\ldlogon
    ConfigProcessors=0
    ImageHWType=0
    ImageOSType=0
    ImageProcessorType=0
    RemoteProcessorPath=%windir%\inf\hal.inf
    ConfigAdvancedMCast=0
    UseWOL=FALSE
    WOLSeconds=120
    DiscoveryType=0
    MaxTMCThreads=5
    MinTMCSleep=1
    MaxTMCSleep=200
    BANDWIDTH_WAN=100
    BANDWIDTH_LAN=100
    SubrepTTL=14
    TargetTTL=2
    [OWNER]
    GUID=8a3ad042-dec6-452e-a67f-828effa78284
    OSDPLUG=TRUE
    DESCRIPTION=
    NAME=D-MAN-LT-XP(32)
    TYPE=WinPE
    [JOBPARAM]
    ABORT_ON_CMD_FAILURE=1
    TASK_COMPLETION_ENABLED=FALSE
    AUTOCOMPUTERNAME=MAN-LT-nnn
    AUTOCOMPUTERNAMESTARTNUMBER=1
    [MACHINES]
    REMEXEC0=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/bootfile.exe"
    REMEXEC1=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tlibr16.dll"
    REMEXEC2=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tlibr32.dll"
    REMEXEC3=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/lddefrag.exe"
    REMEXEC4=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/cicfgmgr.vxd"
    REMEXEC5=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/cindis.vxd"
    REMEXEC6=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/copyfile.exe"
    REMEXEC7=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tokreplw.exe"
    REMEXEC8=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/boot.img"
    REMEXEC9=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/ChangeBCD.exe"
    REMEXEC10=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/BCD"
    REMEXEC11=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/files/bcdedit.exe"
    REMEXEC12=<qt/>%LDMS_CLIENT_DIR%\ChangeBCD<qt/> <qt/>%LDMS_CLIENT_DIR%\bcdedit.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\BCD<qt/>
    REMEXEC13=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /dest="C:\boot.wim" /p="http://%CUSTJOBHOSTIP%/landesk/vboot/boot.wim"
    REMEXEC14=<qt/>%LDMS_CLIENT_DIR%\copyfile.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\boot.img<qt/> <qt/>%LDMS_CLIENT_DIR%\BCD<qt/> \boot\BCD
    REMEXEC15=<qt/>%LDMS_CLIENT_DIR%\lddefrag.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\boot.img<qt/>, STATUS
    REMEXEC16=<qt/>%LDMS_CLIENT_DIR%\bootfile.exe<qt/> %LDMS_CLIENT_DIR%\boot.img /keep /bootunsafe, ASYNC
    BEGINWINPE=TRUE
    REMPING17=WINPE, TIMEOUT=1800
    REMEXEC18=ldrun drvmap.exe (***DOMAIN***)\(****USER*****) (****PASS HASH******) Z: """\\blnfs01.(***DOMAIN***)\landeskimages""", STATUS FACILITY=3513
    REMEXEC19=ldrun drvmap.exe (***DOMAIN***)\(****USER*****) (****PASS HASH******) Y: """\\wddlds01.(***DOMAIN***)\ldmain""", STATUS FACILITY=3513

    REMEXEC20=ldrun sdclient /f /o /dest="X:\LDClient\LDPathExist.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/LDPathExist.exe", STATUS

    REMEXEC21=ldrun LDPathExist.exe """Z:\LAB\XP(32)\Live\FTM-HII-012.TBI""", STATUS
    REMEXEC22=ldrun LDPathExist.exe """Y:\osd\imagew 2\imagew.exe""", STATUS
    REMEXEC23=diskpart /s X:\LDClient\rmvol.txt
    REMEXEC24=diskpart /s X:\LDClient\WIPECLEANDISK0.TXT
    REMEXEC25=ldrun Y:\osd\IMAGEW~1\imagew.exe /r /o /d:0 /f:"""Z:\LAB\XP(32)\Live\FTM-HII-012.TBI""" /rb:0
    REMEXEC26=ldrun sdclient /f /o /dest="X:\LDClient\diskinfo.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/diskinfo.exe", STATUS
    REMEXEC27=ldrun sdclient /f /o /dest="X:\LDClient\assvol2.txt" /p="http://%CUSTJOBHOSTIP%/landesk/files/assvol.txt", STATUS
    REMEXEC28=ldrun sdclient.exe /f /o /dest="x:\ldclient\RMVOLLETTER.TXT" /p="http://%CUSTJOBHOSTIP%/landesk/files/RMVOLLETTER.TXT"
    REMEXEC29=ldrun tokreplw X:\LDClient\assvol2.txt partition=1
    REMEXEC30=diskpart /s X:\LDClient\RMVOLLETTER.TXT
    REMEXEC31=diskpart /s X:\LDClient\assvol2.txt
    REMEXEC32=ldrun sdclient.exe /f /o /dest="x:\ldclient\fixvista.bat" /p="http://%CUSTJOBHOSTIP%/landesk/files/FixVista.bat"
    REMEXEC33=ldrun sdclient.exe /f /o /dest="x:\ldclient\fixntfs.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/fixntfs.exe"
    REMEXEC34=ldrun sdclient.exe /f /o /dest="x:\ldclient\bcdedit.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/bcdedit.exe"
    REMEXEC35=ldrun sdclient.exe /f /o /dest="x:\cba8\FixWindows.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/FixWindows.exe"
    REMEXEC36=ldrun x:\cba8\FixWindows.exe 1
    REMEXEC37=ldrun sdclient /f /o /dest="C:\sysprep\sysprep.inf" /p="http://%CUSTJOBHOSTIP%/landesk/files/D-MAN-LT-XP(32).inf", STATUS
    REMEXEC38=ldrun sdclient /f /o /dest="C:\ldsleep.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/ldsleep.exe", STATUS
    REMEXEC39=ldrun tokreplw C:\sysprep\sysprep.inf COMPUTERNAME=%Computer - Device Name%
    REMEXEC40=cmd /c copy /y X:\LDClient\guid.pds C:\LDISCAN.CFG
    REMEXEC41=ldrun tokreplw C:\LDISCAN.CFG DEVICEID=%Computer - Device ID%
    REMEXEC42=ldrun tokreplw C:\LDISCAN.CFG IMAGEPATH=\\blnfs01.(***DOMAIN***)\landeskimages\LAB\XP(32)\Live\FTM-HII-012.TBI
    REMEXEC43=ldrun diskinfo extend_last_partition
    REMEXEC44=ldrun sdclient.exe /f /o /dest="x:\ldclient\HIIClient.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/HIIClient.exe"
    REMEXEC45=ldrun drvmap.exe (***DOMAIN***)\(****USER*****) (****PASS HASH******) J: """\\WDDLDS01\ldmain""", STATUS FACILITY=3513
    REMEXEC46=ldrun /qt HIIClient /Autodetect /ostype="WinXP" /UNCPath=\\WDDLDS01\ldmain\landesk\files\drivers
    REMEXEC47=ldrun reboot, timeout=2

  • Rookie 27 posts since
    Aug 13, 2010

    Has received 1 of 9 achievements.
    Currently Being Moderated
    8. Feb 10, 2011 12:25 PM (in response to xavier.usclat)
    Re: drvmap error during image deployment

    I think I have narrowed it down to what is having the problem. For us the only times we run into this problem with the default drive letters of H and I is when we are imaging a machine with card readers (SD, etc, etc). When we get the machine up and booted I find that those are taken up to H on our machines. The machines without card readers with 2 or more different slots work perfect with the default script. That is what I have gotten from my results. Hope this helps others.

  • dparham Rookie 6 posts since
    Mar 2, 2011

    Has received 1 of 9 achievements.
    Currently Being Moderated
    9. Oct 20, 2011 2:09 PM (in response to tenletters)
    Re: drvmap error during image deployment

    I was having the same issue with a Lenovo E20.  It has an installed media reader (SD, MMC, etc..)  I changed the driver letters from I: and H: to Y: and Z:.  It is working for me.

     

    dp

  • Rookie 27 posts since
    Aug 13, 2010

    Has received 1 of 9 achievements.
    Currently Being Moderated
    10. Oct 20, 2011 2:50 PM (in response to dparham)
    Re: drvmap error during image deployment

    I actually recently submitted a enhancement request for this. You can see it here:

     

    http://community.landesk.com/support/ideas/2558

  • Andy Martinez Rookie 22 posts since
    Nov 10, 2009

    Has received 1 of 9 achievements.
    Currently Being Moderated
    11. Mar 28, 2012 12:53 PM (in response to Ty)
    Re: drvmap error during image deployment

    What about for SP3? Is there a different process or fix if I am getting this error post SP3 install?

    Attachments:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 20 points
  • Helpful Answers - 10 points
LANDESK Community powered by Jive SBS® 4.5.7.1  |  Legal Notices  |  Privacy Policy  |  Icon 

TweeterOn Twitter  |  Icon FacebookOn Facebook © 2007 LANDESK Software