Skip navigation
8249 Views 5 Replies Latest reply: Apr 22, 2011 9:56 AM by AspenSkier RSS
jason.joubert@emerson.com Rookie 8 posts since
Apr 19, 2009

Has received 1 of 9 achievements.
Currently Being Moderated

Jun 24, 2009 8:03 AM

LANDesk clients are not picking up Portal Policies

I am trying to open up a ticket for this online but the button has disappeared. Is that no longer an option??? Please advise for future reference.

 

One of my admins is trying to make software available on the Software Deployment Portal but none of her LANDesk clients are showing any policies available.

 

Please see attached screenshot.

 

thanks

Attachments:
  • Mach6 Employee 637 posts since
    May 23, 2008

    Has received 6 of 9 achievements.

    The ability to create a case should still exist, as long as your user name has been associated with your account.  Using amazing powers of deductive reasoning I figured out what your real name is and looked you up in our customer database.  You should be able to create and edit cases without any problem.

     

    As far as the question you've got here, are the policies listed as required, recommended, or optional?  Only recommended and optional policies will appear in the software deployment portal, required policies just run.

  • Gerald Ashby SupportEmployee 57 posts since
    Mar 7, 2008

    Has received 3 of 9 achievements.

    Jason;

     

    In regards to opening a case via the web. Yes this still very much an option. On the front page of http://community.landesk.com there will be a link fo "Smart Self-Service Portal". You will then have a couple of options, one of them will be "get help with a new case". Once you click on this link it will prompt you for information about the type of case that you are looking for. Once you fill out that information and submit it you will be given a few articles that match your criteria in hopes that you will find a quick resolution to your issue. If you do not find the sollution to your problem then you will  have the option toward the bottom of the solutions to open a new case. There are a few more steps here than there were traditionally, but we hope that this will actually speed up the resolution of your issue.

     

    Now in regards to the policy not showing up in the policy window. There are a couple of things to check. First make sure that the policy deliver method is set to an available method. For example, required polcies will just run and wont show up in the portal. But "always available will show up there" among others. The next thing you need to do is to check the polciy.sync.log (in the ..\Program Files\LANDesk\LDClient directory). What I would do is rename this log to policy.sync.log.old. Then re-run policy.sync.exe and check the log. You should see the policies being downloaded. It would be helpful to see the results of this log.

     

    Please post the details of the polciy.sync.log and let us know the delivery method that you are using.

  • mrspike SSMMVPGroup 1,313 posts since
    Dec 19, 2007

    Has received 9 of 9 achievements.

    If your policies are set correctly, than there is good chance the local database on the client is corrupt.  We found that this happens a lot and I use a .bat software task that is easy to use and fixes this and many other policy issues.

     

    Once you run this it may take a few minutes to populate the portal, but it you refresh it a few times you should see items appearing in it.

     

    I forgot how to show this as "code", I have also attached it as a text file, just make it a .bat file, and create a sofware package.  It is safe to deploy as needed, even it a system is "healthy".

     

     

     

     

     

    : This script will delete the clients landesk database, recreate it, validate it and clean up
    : old xml files/  Any xml files that are still required will repopulate as needed
    : this is also good at fixing portal and other policy issues
    :
    cmd /c del "c:\documents and settings\all users\application data\landesk\managementsuite\database" /q
    del "C:\Documents and Settings\All Users\Application Data\LANDesk\ManagementSuite\landesk\files" /q
    del "C:\Documents and Settings\All Users\Application Data\vulScan\*.xml" /q
    del "C:\Program Files\LANDesk\LDClient\sdmcache\landesk\files\*.xml" /q
    net stop "Landesk Policy Invoker"
    "c:\program files\landesk\ldclient\clientdbutil.exe" /create
    "c:\program files\landesk\ldclient\clientdbutil.exe" /validate
    net start "Landesk Policy Invoker"
    "c:\program files\landesk\ldclient\policy.sync.exe"
    "c:\program files\landesk\ldclient\policy.client.invoker.exe"
    EXIT /B 0

    Attachments:
  • Employee 620 posts since
    Dec 12, 2007

    Has received 6 of 9 achievements.
    Currently Being Moderated
    4. Jun 24, 2009 10:27 AM (in response to mrspike)
    Re: LANDesk clients are not picking up Portal Policies

    Are you on sp3.  If not attach your policy.sync.exe.log to the post.  There is a known issue on sp2 systems.  It could also be as simple as re-creating your local database on the system in question.  Followin the steps James provided.

  • AspenSkier Specialist 479 posts since
    Apr 29, 2010

    Has received 3 of 9 achievements.
    Currently Being Moderated
    5. Apr 22, 2011 9:56 AM (in response to Ty)
    Re: LANDesk clients are not picking up Portal Policies

    does anyone know if this maintenance fix is still relevant for 9.0 SP2?

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • Correct Answers - 20 points
  • Helpful Answers - 10 points
LANDESK Community powered by Jive SBS® 4.5.7.1  |  Legal Notices  |  Privacy Policy  |  Icon 

TweeterOn Twitter  |  Icon FacebookOn Facebook © 2007 LANDESK Software