Console login is very slow after applying SP2

    Description:
    Console login is very slow after applying SP2. The ResolveUserGroups.exe.log shows that resolving users and groups is taking a long time to run:

     

    12/01/2010 18:09:13 INFO  13772:1     RollingLog : ResolveUserGroups Started
    12/01/2010 18:09:14 INFO  13772:1     RollingLog :   10 second TTL for group queries
    12/01/2010 18:09:14 INFO  13772:1     RollingLog :   10 second TTL for local landesk security group queries
    12/01/2010 18:09:14 INFO  13772:1     RollingLog : Resolving 65 Groups
    12/01/2010 18:59:10 INFO  13772:1     RollingLog : Resolution for groups complete (49 Minutes, 58 Seconds, 243 Milliseconds)
    12/01/2010 18:59:10 INFO  13772:1     RollingLog : Resolving 52 Users
    12/01/2010 19:38:23 INFO  13772:1     RollingLog : ResolveUserGroups Complete (29 Minutes, 11 Seconds, 27 Milliseconds)

     

    Cause:
    As of LDMS 9, SP2, there is a utility called Resolveusergroups.exe. This utility runs periodically (every 20 minutes) to refresh the list of LANDesk Management Suite console users.

     

    Once the user list is resolved, it is placed in cache and used until Resolveusergroups.exe runs again. In some Active Directory environments, if the TTL values are too small, some of the resolved user accounts may have crossed the TTL threshold before all of the accounts are resolved. This causes the cache to be refreshed again and again, and the console loads very slowly.

     

    Resolution:

    Change the default TTL settings for Resolveusergroups.exe. You can run Resolveusergroups.exe /? to see its usage. The TTL values are in seconds. This is a specific example that sets the TTL values to the maximum:
    Resolveusergroups.exe /verbose /TTL  600 /LDTTL 60

     

    Any changes to the TTL values are written to the KeyValue table in the database (GroupResolutionTTL and LocalLDGroupResolutionTTL), so they are persistent.