1 2 Previous Next 15 Replies Latest reply: Oct 13, 2009 9:33 AM by dynamozappa RSS

    resident agent will not run/install

    dynamozappa Apprentice

      This has been happening to me with provisioning (i have several other threads posted) where the Configure target OS stage of the template will fail at the point where it tries to install the resident agent. But even on a machine that has a LANDesk Agent installed on it, the resident agent will not start....so i can't communicate with the device from the core....which renders LANDesk useless.

       

      When i try to provision a machine, i get this error: RAInstall result 1073741825

      I have tried to google that particular error but I have found nothing. i have attached the complete log.

       

      When I just try to go to a machine that has an agent already installed and run rainstall.exe, i get this error: RAInstall result 0

      And if i try to run residentagent.exe, i see it running in the task manager for a second and then it disappears. I am stumped...and frustrated.

       

      I have tried to find the latest version of rainstall.exe and put them in all the right places but again, nothing. And my core is running 8.8, SP3.

       

      Someone please help before my boss starts to think I don't know what I am doing....maybe i don't but he doesn't have to know that.

       

      thanks.

       

      jeff

        • 1. Re: resident agent will not run/install
          phoffmann SupportEmployee

          Do you have any more luck if you run this command line (needs to be run from the Core's LDLOGON directory):

          ""

          RAINSTALL /INSTALL /FORCE
          ""

           

          Alternatively, if only the "Management Agent" is missing, the following could help -- run "residentagent.exe /register" from the "C:\Program Files\LANDesk\Shared Files\"-directory

           

          This is presently meant less as a solution but more as a work-around / just to find out what's actually broken (the logic being that - by knowing how to fix it, we know where we need to look for what's broken).

           

          - Paul Hoffmann

          LANDesk EMEA Technical Lead

          • 2. Re: resident agent will not run/install
            dynamozappa Apprentice

            hey Paul,

             

            Thanks....I am going to try that when i get a chance. I think you are on to something though with the registration of residentagent.exe. I got the log file from a machine that I tried to run residentagent.exe on. It says that the service was not registered. And also it says "could not start ctrl dispatcher." I have no idea what that means. I have attached the log below.

             

            Also i noticed that the version of residentagent.exe is 8.8.0.29 whereas the version of rainstall.exe is 8.8.0.35. Seems like that would be an obvious cause of the failure of the installation. Do you know what may have caused the discrepancy between versions? And where can I put the latest versions of both files to make sure that they are deployed when installing agents and provisioning?

             

            thanks

             

            jeff

            • 3. Re: resident agent will not run/install
              dynamozappa Apprentice

              So i tried registering residentagent.exe and it appears to have registered correctly but when i try to actually run it, it pops up in task manager for a second then disappears.

               

              I also tried to force the install of rainstall from the ldlogon share and it still didn't work. The log file is the same...."could not start ctrl dispatcher." it is either that or the version discrepancy that is the source of my resident agent woes.

               

              jeff

              • 4. Re: resident agent will not run/install
                phoffmann SupportEmployee

                The only time I've seen THAT particular error message was when the logged-on user(s) were members of more groups than Windows could cope enumerating, so things like "LDAPWHOAMI" would fail (try to run it, see if it works).

                 

                In regards to versions - it should not necessarily be assumed that "all files of 8.80.0.29" must be going with files of the same version ... if your problem is not AD-related (just run LDAPWHOAMI from the command-line prompt), then it may be time to open a ticket and get some more CBA'y specialist to have a look as to what's going on .

                 

                - Paul Hoffmann

                LANDesk EMEA Technical Lead

                • 5. Re: resident agent will not run/install
                  dynamozappa Apprentice

                  Ok...so i can't find "ldapwhoami." i tried to run it from the command prompt but nothing. Where is that file located? Also, you said "The only time I've seen THAT particular error message was when the logged-on user(s) were members of more groups than Windows could cope enumerating..." Would it matter if I was just logging in to the machine as the local administrator? The local administrator is only a member of the local administrators group.

                   

                  I did take the machine off of our domain and when I restarted it residentagent.exe was running. So I tried to connect to it from from the core (just to run an inventory scan, i could not remote control it at all) but I got the same old error "CBA8, unable to contact remote agent." If this was an AD problem and the groups could not be enumerated, shouldn't I be able to connect to the machine if it was taken off the domain?

                   

                  thanks.

                   

                  jeff

                  • 6. Re: resident agent will not run/install
                    phoffmann SupportEmployee

                    LDAPWHOAMI is in the LDLCIENT directory - it's one of our things.

                     

                    It shouldn't make a difference if you logged on as a local administrator (if anything, it should make it better) - but we may still try to enumerate AD-groups that the user is a member of (if any).

                     

                    If resident agent was running once you took out of the domain that's ... odd ... but - what you want to do is to check the SERVICEHOST.LOG file (in "C:\Program Files\LANDesk\Shared Files\") ... see whether the server was able to authenticate to the client ... that log file is essentially a log of "what I've been told to run // how (some) authentication went...".

                     

                    - Paul Hoffmann

                    LANDesk EMEA Technical Lead

                    • 7. Re: resident agent will not run/install
                      dynamozappa Apprentice

                      Paul,

                       

                      here is the servicehost.log. I cannot tell if it is authenticating or not. I don't like the "expired cert" error. Is that normal?

                       

                      it also says this: "EOF encountered parsing HTTP headers, client closed connection." Could this be an IIS problem from the core?

                       

                      Also, i pasted the result of running "ldapwhoami" into the log file. Looks like nothing is happening.

                       

                      thanks.

                       

                      jeff

                       

                      p.s. why is the loopback address listed instead of the actual IP?

                      • 8. Re: resident agent will not run/install
                        dynamozappa Apprentice

                        hey paul.....         

                        don't mean to rush you but i was wondering if you have any more suggestions....should I go ahead and put in a support ticket with LD? kinda stuck here and the boss is getting antsy....thanks.

                         

                        jeff

                        • 9. Re: resident agent will not run/install
                          phoffmann SupportEmployee

                          If it's urgent, I'd ALWAYS recommend logging a ticket with support. Urgent issues shouldn't rely on community too much as it's more of a "as folks have spare time" type affair.

                           

                          It being end of quarter on top of the usual hussle and bussle, I've got my arms pretty full, and I can only afford to spend so much time on the community (I do try), so if I don't get back to you it's usually because I'm buried elsewhere .

                           

                          But yes - go for it - log a ticket with support, that way you've got a more reliable contact (as I'm somewhat a slave to my outlook calendar at the moment).

                           

                          Apologies for not responding earlier - I don't ignore folks intentionally, honest.

                           

                          - Paul Hoffmann

                          LANDesk EMEA Technical Lead.

                          • 10. Re: resident agent will not run/install
                            dynamozappa Apprentice

                            i really do appreciate your help....i do know you must be very busy and i know you would never ignore someone intentionally. It still isn't an urgent issue but i was just hoping i could get it resolved myself (or with the help of the forums) with out going through support. But I will be glad to call.

                             

                            Thanks so much. You have been a huge help!

                             

                            jeff

                            • 11. Re: resident agent will not run/install
                              dynamozappa Apprentice

                              what happens if i put in a support ticket and I never hear back from Landesk? You have been way more reliable than they have.

                              • 12. Re: resident agent will not run/install
                                phoffmann SupportEmployee

                                List up the case # and I'll try to see where / why it's stuck, and get it rolling.

                                 

                                - Paul Hoffmann

                                LANDesk EMEA Technical Lead

                                • 13. Re: resident agent will not run/install
                                  dynamozappa Apprentice

                                  Hey Paul,

                                   

                                  I never got a case number. I will give them a call back....thanks.

                                   

                                  jeff

                                  • 14. Re: resident agent will not run/install
                                    dynamozappa Apprentice

                                    hey Paul,

                                     

                                    Talked to Jed there at LD headquarters and he has fixed my problem. Turns out it was the cba8inst.exe file on my core. It was corrupted i guess. He sent me a new one and BOOM, i am a provisioning FOOL! Man i love landesk when it works right.

                                     

                                    So thanks for all the help.

                                     

                                    jeff

                                    1 2 Previous Next