4 Replies Latest reply: Nov 23, 2010 7:57 AM by jabramson RSS

    Machines failing patches with error code 412, Landesk 9

    Rookie

      I'm running Landesk 9.0 with some machine with SP1 and others without (SP1 fails with error code 412 when patching to SP1). Patches are now failing on the systems with error code 412. This is the vulscan log from one of the machine during a failed patch of Firefox and Adobe Acrobat -

       

      .....

       

      Command Interpreter running
      Executing C:\Program Files (x86)\LANDesk\LDClient\SDMCache\Firefox Setup 3.6.9_ENU.exe -ms
      ERROR: C:\Program Files (x86)\LANDesk\LDClient\SDMCache\Firefox Setup 3.6.9_ENU.exe -ms returned a bad exit code (3221225794)
      ERROR(EXECUTEFILE) Failed to run command  - 80004005
      DownloadPatch ERROR: Failed to run commands (80004005).
      Last status: Failed
      Sending status to core
      In SendRequest: Action = SOAPAction: "http://tempuri.org/SetPatchInstallStatus"
      Tue, 12 Oct 2010 10:46:10 SendRequest: SOAPAction: "http://tempuri.org/SetPatchInstallStatus"
      Last status: Contacting server...
      Tue, 12 Oct 2010 10:46:11 Success
      Last status:
      Last status: Done
      Running patch Firefox Setup 3.6.10_ENU.exe
      ShouldScan Firefox Setup 3.6.10_ENU.exe before repairing returned: 0
      Patch directory : 'C:\Program Files (x86)\LANDesk\LDClient\SDMCache\'
      Patch name : 'Firefox Setup 3.6.10_ENU.exe'
      Command Interpreter running
      Executing C:\Program Files (x86)\LANDesk\LDClient\SDMCache\Firefox Setup 3.6.10_ENU.exe -ms
      ERROR: C:\Program Files (x86)\LANDesk\LDClient\SDMCache\Firefox Setup 3.6.10_ENU.exe -ms returned a bad exit code (3221225794)
      ERROR(EXECUTEFILE) Failed to run command  - 80004005
      DownloadPatch ERROR: Failed to run commands (80004005).
      Last status: Failed
      Sending status to core
      In SendRequest: Action = SOAPAction: "http://tempuri.org/SetPatchInstallStatus"
      Tue, 12 Oct 2010 10:46:12 SendRequest: SOAPAction: "http://tempuri.org/SetPatchInstallStatus"
      Last status: Contacting server...
      Tue, 12 Oct 2010 10:46:13 Success
      Last status:
      Last status: Done
      Running patch AcrobatUpd940_all_incr.msp
      ShouldScan AcrobatUpd940_all_incr.msp before repairing returned: 0
      Patch directory : 'C:\Program Files (x86)\LANDesk\LDClient\SDMCache\'
      Patch name : 'AcrobatUpd940_all_incr.msp'
      Command Interpreter running
      Executing C:\Windows\System32\msiexec.exe /q /p "C:\Program Files (x86)\LANDesk\LDClient\SDMCache\AcrobatUpd940_all_incr.msp"
      ERROR: C:\Windows\System32\msiexec.exe /q /p "C:\Program Files (x86)\LANDesk\LDClient\SDMCache\AcrobatUpd940_all_incr.msp" returned a bad exit code (3221225794)
      ERROR(EXECUTEFILE) Failed to run command  - 80004005
      DownloadPatch ERROR: Failed to run commands (80004005).
      Last status: Failed
      Sending status to core
      In SendRequest: Action = SOAPAction: "http://tempuri.org/SetPatchInstallStatus"
      Tue, 12 Oct 2010 10:46:14 SendRequest: SOAPAction: "http://tempuri.org/SetPatchInstallStatus"
      Last status: Contacting server...
      Tue, 12 Oct 2010 10:46:14 Success
      Last status:
      Last status: Done
      Running patch AdobeAIRInstaller2.0.4.exe
      ShouldScan AdobeAIRInstaller2.0.4.exe before repairing returned: 0
      Patch directory : 'C:\Program Files (x86)\LANDesk\LDClient\SDMCache\'
      Patch name : 'AdobeAIRInstaller2.0.4.exe'
      Command Interpreter running
      Executing C:\Program Files (x86)\LANDesk\LDClient\SDMCache\AdobeAIRInstaller2.0.4.exe -silent
      Specified timeout is 3000 seconds
      ERROR: C:\Program Files (x86)\LANDesk\LDClient\SDMCache\AdobeAIRInstaller2.0.4.exe -silent returned a bad exit code (3221225794)
      ERROR(EXECUTEFILE) Failed to run command  - 80004005
      DownloadPatch ERROR: Failed to run commands (80004005).
      Last status: Failed
      Sending status to core
      In SendRequest: Action = SOAPAction: "http://tempuri.org/SetPatchInstallStatus"
      Tue, 12 Oct 2010 10:46:15 SendRequest: SOAPAction: "http://tempuri.org/SetPatchInstallStatus"
      Last status: Contacting server...
      Tue, 12 Oct 2010 10:46:16 Success
      Last status:
      Last status: Done
      Any ideas?? Thanks!

       

      I believe all of this started happening when I patched the management server to SP1 back in August.