9 Replies Latest reply: Dec 22, 2011 4:13 PM by Tanis RSS

    Scheduled Reports

    jholebrook Rookie

      I've tried setting up a report that I've created from a query and then creating a Schedule Report by email.  Its not running to I've checked the services on the server and made sure they are running but its still not working.  I can email the report to myself from the actions menu within Service Desk.

       

      Any ideas what I could check? Any help would be appreciated.

       

      Jacqueline

        • 1. Re: Scheduled Reports
          blaine67 Apprentice

          There is one more service that needs to be active for this, which is not started by default.

           

          It's the 'Touchpaper Query Reports Engine' service.

           

          You did mention you had checked service, but I thought I'd ask as it's usually not started.

          • 2. Re: Scheduled Reports
            jholebrook Rookie

            Thank you for the quick response. This service is one I switched on before I posted but I am still not getting the report automatically.

             

            I have got an Application error in the Server Event Log.

             

            Outbound Mail Engine

             

            There was an error generating the XML document.

             

            I seem to be getting these once an hour so I am going to try deactivating the scheduled report for now and see if they stop.

             

            Jacqueline

            • 3. Re: Scheduled Reports
              Rookie

              I too have the same issue.  The reports scheduled correctly initially, but I changed the time/date settings to test changes to the query and then all of a sudden the schedular stopped working altoegther.

               

              All the required services are working (Outbound Mail Engine, Query Reports Engine, Inbound Email and Services Background).

              • 4. Re: Scheduled Reports
                Apprentice

                Check your application Log to see if your not getting an error with the actual email thats going out.  I had some issues with when i would select the option add report as attachement.  It might be that the scheduler is working but the email is bombing out due to some reason or another.  

                • 5. Re: Scheduled Reports
                  cgodden Apprentice

                  I have the same issue. Not sending them as an attachment and there is not a error in event log. It gives no feed back. Also created a query to look at messages going out and they do not show up in there

                  • 6. Re: Scheduled Reports
                    Expert

                    A few things to check (some have been mentioned already)-

                     

                    1. Services are running (background processing, query reports engine and outbound mail engine)
                    2. Recipients have been added to the report schedule
                    3. The schedule is active (you can activate or deactivate scheduled tasks and reports, if the icon next to the report is grey it is inactive)
                    4. Is anything returned by the report? If not then it doesn't send a report. Scheduled reports are only sent if they return some data at the time of running/sending
                    5. Is the notification method for all recipients set to External? if not they will not receive a notification

                     

                    Hope this helps.

                     

                    Cheers,

                    Hadyn

                    • 7. Re: Scheduled Reports
                      JulianWigman Expert

                      One other thing to be aware of is that the password in the Query reports engine config file is not updated by the password update tool so might be worth checking that this (it's encrypted though) is set correctly.  Hopefully you use the same user as in the other configs so can simply compare/sync this password with one from one of the other server configs.

                       

                      Julian

                      • 8. Re: Scheduled Reports
                        cgodden Apprentice

                        Just FYI i applied the latest roll up patches to my application server and it fixed this issue. Previosly had only applied to web server

                        • 9. Re: Scheduled Reports
                          Rookie

                          Finally figured out our problem, I didn't have anything in the 'subject' in the information section just under the recipients which in turn looks like ignored sending the email to the recipient.

                           

                          Thanks for all you suggestions, I'll keep them in mind.