5 Replies Latest reply: Feb 25, 2012 5:41 PM by dmshimself RSS

    Email - Can't Connect to Server

    Adam Wilden Expert

      Hi,

       

      We are again seeing LanDesk SD failing to connect to our email server periodically.

       

      It might work well for a day or so and then suddenly fails - the only message we get is that it can't connect to the server (this is on full error level).

       

      Other support systems we use continue to connect OK and we can open the mailboxes OK via OWA etc so it's not the Exchange end.

       

      The problem is that once it can't connect - it then won't connect to any other mailbox (we connect to 5).

       

      Restarting the inbound service doesn't fix it - we have to actually reboot the server (2003)).

       

      We've tried running the inbound mail in Systray rather thanas  a service, and also installed it on another server (2008)  but the problem still occurs.

       

      We wouldn't mind the connection failing periodically (this has always happened ocassionally) if it then went on to connect next time, but restarting a live server after each failure is casuing us a lot of problems.

       

      Has anyone else seen this?  Or got any ideas?

       

      We've trawled the net for answers but not found anything useful - but as stated other products using similar connections don't have this issue so I suspect it's unique to LDSD.  We are running v7.4 on Server 2003 fully patched.  We've disabled AV but this made no difference.  Service can connect most times so not a rights issue. 

       

       

      Thanks - Adam.

        • 1. Re: Email - Can't Connect to Server
          gman1981 Apprentice

          Hi Adam,

           

          We sporadically have this issue as well. It seems an e-mail get's stuck in the mailbox and LDSD refuses to read anything after that. We just assumed up to now that as we are connecting to Lotus Notes it was another one of the many 'features' of Lotus Notes/Domino that was causing the problem. We end up having to go through one by one in the mailbox to find the dodgy email and then remove it. Once done the rest get processed right through. I haven't tried rebooting the LDSD server to see if it fixes though.

           

          Not sure if any of that helps?

           

          Dave

          • 2. Re: Email - Can't Connect to Server
            Adam Wilden Expert

            Hi Dave,

             

            I think what we are seeing is slightly different.  It doesn't matter what email it is (or even if there are any emails waiting to be picked up).

             

            It just fails to connect.

             

            After a reboot it usually connects fine and then will read all emails that are waiting.

             

            (we also get the odd email it can't read - usually if in chinese/korean - but it just skips these).

             

            Thanks - Adam.

            • 3. Re: Email - Can't Connect to Server
              gman1981 Apprentice

              Ahh ok -  Maybe ours is just Lotus Notes then!

              • 4. Re: Email - Can't Connect to Server
                Adam Wilden Expert

                I remember when we all used either Notes or Groupwise....

                 

                Now our Director is talking about outsourcing our email to the "Cloud" (everyone's favourite word these days).

                 

                TBH I don't think our problem is with LanDesk SD itself - just wondered if anyone else had encountered it or had any ideas.

                 

                Cheers - Adam.

                • 5. Re: Email - Can't Connect to Server
                  dmshimself ITSMMVPGroup

                  I'd set up an application pool for the TPS inbound is using and do a pool recycle at (say) 2am every day.  It will not fix the problem, but might reduce the frequency.  At the time it happens, I'd also do a telnet connection on the server to the right port on the mail server and see what comes back.  If an announcement for some sort of IMAP service doesn't appear from the mail server, then indeed the issue is nothing to do with LANDesk. (and the opposite is also true).  If you can connect on the IMAP port and have recycled the pool and inbound still fails to conenct, then I'd be asking your local LANDesk support team to be on standby to set up a remote session for them to take a look.