2 Replies Latest reply: Mar 15, 2012 10:44 AM by dcb RSS

    Outbound mail engine errors

    dcb Rookie

      Hi,

      I'm having problems on our Dev server with outbound mail.  I have run through all the documentation and advise that I could find regarding the set up and compared the relevant config files containing the encryted password for SA account with the Live system and everything looks as it should.

       

      However I cannot start the tray icon for the mail engine and when I stop and start the service (separately and not both running) it takes a long time.  One of the errors is regarding log on:

       

      Description:
      TPS : Mail Outbound Failed To Logon

       

      Another error is :

       

      Description:
      Application: Touchpaper.Service.Mail.Outbound.SystemTray.exe
      Framework
      Version: v4.0.30319
      Description: The process was terminated due to an unhandled exception.Exception Info: System.ObjectDisposedExceptionStack:   at System.Windows.Forms.Control.CreateHandle()  
      at System.Windows.Forms.Form.CreateHandle()
         at System.Windows.Forms.Control.get_Handle()
         at System.Windows.Forms.Control.SetVisibleCore(Boolean)
         at System.Windows.Forms.Form.SetVisibleCore(Boolean)
         at System.Windows.Forms.Control.set_Visible(Boolean)
         at System.Windows.Forms.Application+ThreadContext.RunMessageLoopInner(Int32,
      System.Windows.Forms.ApplicationContext)  
      at System.Windows.Forms.Application+ThreadContext.RunMessageLoop(Int32,
      System.Windows.Forms.ApplicationContext)  
      at System.Windows.Forms.Application.Run(System.Windows.Forms.Form)
         at Touchpaper.Service.Mail.Outbound.SystemTray.OutboundSystemTray.Main(
      )

       

      and a "Failed to stop service" error:

       

      Failed to stop service. System.NullReferenceException: Object reference not set to an instance of an object.
         at Touchpaper.Service.Mail.Outbound.WindowsService.OutboundMailService.OnStop()
         at System.ServiceProcess.ServiceBase.DeferredStop()

       

       

      Can anyone shed any light on this please? (BTW the password in the config files for Dev & Live are the same - live is working!)

       

      Thanks in advance.

       

      David

       

      Message was edited by: dcb Forgot to mention ->  version 7.4

        • 1. Re: Oubound mail engine errors
          aparker Employee

          The one thing I noticed about this is that on your Dev environment, you're using the system tray icons rather than the service. Are you using the service in live?

           

          if you try and use the service in Dev is it ok? I ask because I suspect the issue is that the login credentials have not been correctly updated for the system tray config files.

           

          Hope that make some kind of sense?

           

          Andy

          • 2. Re: Oubound mail engine errors
            dcb Rookie

            Hi Andy, I've tried both (but not at the same time). The log errors are from when trying both. - Dave