2 Replies Latest reply: Dec 8, 2011 10:08 PM by paul.enkelaar RSS

    Is it possible to use run-time values in Template Designer?

    Expert

      Hi all

       

      As the subject says, I was wondering if it is possible in any way to use run-time values when setting up templates.

       

      For example, in Request Management, I have an authorisation step required.  In general, the request will go to the Raise-user's manager (as specified in the User's properties in Admin module).  To cater for people being on leave etc, I have placed the "Authoriser" (user link) on the main window to allow the raise-user to select who is going to authorise their request.  However, I would like the default value displaying on the window (via the template I have set up) to be the manager of the user, but I cannot seem to be able to use run-time values here.

       

      Right-clicking on the attribute gives me the image shown in the attachment:

      authoriser.jpg

       

      Is it just me?  Should this be an ER?

       

      Cheers


      Paul

        • 1. Re: Is it possible to use run-time values in Template Designer?
          JulianWigman Expert

          Hey Paul,

           

          Wouldn't you instead use a Business Object Copy Rule on the Request BO in Window Manager to populate the Authoriser field as soon as the requester is picked.   Then on the raise use field set the copy related attribute to true.

           

          That would seem more appropriate that a template which as you've discovered can only take static values.

           

          Regards

           

          Julian

          • 2. Re: Is it possible to use run-time values in Template Designer?
            Expert

            Hi Julian

             

            Thanks for your help here.  I hadn't really played around with Copy Rules before, so good to know they are there to use.  It didn't go exactly as planned, as I would have like to be able to use it on the "Initialise" event, but it appears you are limited to CurrentUser and CurrentGroup when using Initialise.  I was able to tweak my process slightly to allow it to be workable populating the Authoriser user on a "Create" event.

             

            Thanks again.

             

            Paul